Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 19

Thema: VC-1 zu h.264 oder HEVC Graue Frames am Anfang

  1. #1
    Grünschnabel
    Registriert seit
    5. January 2018
    Beiträge
    8

    Standard VC-1 zu h.264 oder HEVC Graue Frames am Anfang

    Ich habe ein Paar Blu-rays im VC-1 Codec, die ich versuche zu rippen.
    Leider hat das Ergebnis aber jedes Mal ein Paar Graue Frames gleich am Anfang.

    Der Rest scheint in Ordnung zu sein aber ich weiß ja nicht ob diese Frames nicht auch wo anders vorkommen.

    DGDecNV Habe ich nicht, möchte auch nicht dafür bezahlen.

    Avisource produziert den "could not process frame 0" fehler.

    DirectShowSource produziert minderwertige Qualität.

    Ich habe das Internet rauf und runter gesucht und bin jetzt am Ende meiner Weisheit.

    SCRIPT

    Code:
    #----------------------------------------------------------------------------- F I L T E R S ---------------------------------------------------------------------------------#
    
    
    LoadPlugin		("C:\Program Files (x86)\MeGUI\tools\ffms\ffms2.dll")
    
    
    
    
    #------------------------------------------------------------------------------ S O U R C E ----------------------------------------------------------------------------------#
    
    
    FFVideoSource		("E:\test\Awaiting\VIDEO_VC1.mkv", colorspace="YV12", resizer="Bilinear", width=1280, height=720, fpsnum=24000, fpsden=1001, threads=1)
    
    
    #-------------------------------------------------------------------------- P A R A M E T E R S ------------------------------------------------------------------------------#
    
    
    trim			(1,720)
    Geändert von LigH (5. January 2018 um 15:56 Uhr) Grund: CODE um das Script

  2. #2
    Erklär-Bär Avatar von LigH
    Registriert seit
    19. April 2003
    Ort
    OPAL-Invalidengebiet Altmark
    Alter
    42
    Beiträge
    42.552

    Standard AW: VC-1 zu h.264 oder HEVC Graue Frames am Anfang



    Selbstverständlich kann AviSource kein WMV lesen.

    Eine sehr ähnliche Alternative zu FFMS2 wäre L-SMASH Works (LwLibavVideoSource), die MeGUI bietet beide im "AVS Script Creator" für den "File Indexer" zur Wahl.

    Grundsätzlich wäre es aber denkbar, dass die von beiden Plugins verwendete nachprogrammierte Decoder-Bibliothek vielleicht mal den Anfang nicht korrekt findet und so die erste GOP verpasst. Dennoch sind die beiden Filter nicht ganz identisch. Also zunächst mal vergleichen, wie sich die beiden Video-Source-Funktionen hier vielleicht unterscheiden. Haben beide das gleiche Verhalten, gäbe es noch eine weitere Chance (DSS2 im LAV-Filter-Modus).

    Ich finde übrigens, dass da eventuell zu viele Parameter im Source-Aufruf stehen, aber die hat sicher die MeGUI eingefügt. Könnte man auch mal schauen, ob da weniger Parameter zuverlässiger arbeiten, wenn die Quelle sicher eine konstante Framerate hat; und bilineare Skalierung ist sicher auch nicht die optisch angenehmste, man kann das gleich im Source-Filter machen, aber nachträglich mit separater *Resize-Funktion hat man die größere Auswahl zwischen unterschiedlichen Methoden.

    Auf gute Zusammenarbeit:

    REGELN befolgen | SUCHE benutzen | FAQ lesen | STICKIES beachten




  3. #3
    Kaiser
    Registriert seit
    6. July 2009
    Beiträge
    1.320

    Standard AW: VC-1 zu h.264 oder HEVC Graue Frames am Anfang

    Zitat Zitat von LigH Beitrag anzeigen
    Haben beide das gleiche Verhalten, gäbe es noch eine weitere Chance (DSS2 im LAV-Filter-Modus).
    VC-1 ist auch einer der wenigen Fälle, wo ich DSS/DSS2 mit LAV (DXVA2 copy-back oder Microsoft) gegenüber ffms vorziehen würde, weil ffmpeg mit VC-1 verbuggt ist.

  4. #4
    Grünschnabel
    Registriert seit
    5. January 2018
    Beiträge
    8

    Standard AW: VC-1 zu h.264 oder HEVC Graue Frames am Anfang

    Wie ist Die Syntax für DSS2 im LAV-Filter-Modus? Bzw. Was muss ich wo umstellen?

  5. #5
    Grünschnabel
    Registriert seit
    5. January 2018
    Beiträge
    8

    Standard AW: VC-1 zu h.264 oder HEVC Graue Frames am Anfang

    LSMASH Works ist im File Indexer ausgegraut.

  6. #6
    Kaiser
    Registriert seit
    6. July 2009
    Beiträge
    1.320

    Standard AW: VC-1 zu h.264 oder HEVC Graue Frames am Anfang

    L-Smash basiert ebenfalls auf ffmpeg.

    Für DSS/DSS2 erst DirectShowSource in den Einstellungen aktivieren und LAV installieren.. Dann Tools->AVS Script Creator->Filter. Ich würde für LAV Video/Splitter/Audio auch in den jeweiligen Einstellungen das Tray-Icon aktivieren. Dann siehst Du, ob die wirklich geladen werden.

    Zitat Zitat von EdenElanis Beitrag anzeigen
    DirectShowSource produziert minderwertige Qualität.
    Das ist nicht korrekt. Die Qualität ist normalerweise identisch zu den anderen Filtern. DirectShowSource kann manchmal problematisch sein, z.B. weil die Frames nicht 100% an der korrekten Position sind (ist mit LAV normalerweise aber kein Problem, insbesondere, wenn man nur ein Skript von Anfang bis Ende enkodiert, d.h. ohne Seeken wie Trim()). Außerdem ist schwer zu erkennen, welche Filter wirklich geladen werden. Es gibt noch einen DSS2-Mod, der dafür sorgt, daß nur LAV geladen wird.
    Aus diesen Gründen wird normalerweise eben ffms2 oder l-smash empfohlen, aber bei VC-1 sind die halt buggy, so daß man ausnahmsweise DSS/DSS2 bevorzugt - zumindest ich sehe das so. (DGDecNV möchtest Du ja nicht.)

  7. #7
    Grünschnabel
    Registriert seit
    5. January 2018
    Beiträge
    8

    Standard AW: VC-1 zu h.264 oder HEVC Graue Frames am Anfang

    Ist ja nicht so, dass ich DGDecNV einfach nicht möchte. Es kostet ja Geld.

    Aber mal die Allgemeine Frage gestellt: Wenn man euch vor die Aufgabe stellen würde, eine VC-1 Blu-ray vernünftig zu rippen, wie würdet ihr verfahren?

    Und ich meine den Rip nicht etwa für jemand Anderen sondern für euch selbst.

  8. #8
    Kaiser
    Registriert seit
    6. July 2009
    Beiträge
    1.320

    Standard AW: VC-1 zu h.264 oder HEVC Graue Frames am Anfang

    DirectShowSource mit LAV DXVA2 copy-back. (Habe keine Nvidia-Karte.)

  9. #9
    Grünschnabel
    Registriert seit
    5. January 2018
    Beiträge
    8

    Standard AW: VC-1 zu h.264 oder HEVC Graue Frames am Anfang

    Gut. Wie genau Ist die Syntax dafür?

  10. #10
    Erklär-Bär Avatar von LigH
    Registriert seit
    19. April 2003
    Ort
    OPAL-Invalidengebiet Altmark
    Alter
    42
    Beiträge
    42.552

    Standard AW: VC-1 zu h.264 oder HEVC Graue Frames am Anfang

    Eigentlich meinte ich DSS2Mod (auch für AviSynth+ x64), eine Modifikation, die nicht von der Installation des veralteten Haali Media Splitter abhängt, sondern LAV Filters direkt benutzen kann. Leider ist dieses Projekt (inklusive der benutzten LAV-Filters-Version) auch schon ziemlich alt, und ich bezweifle, dass irgend jemand Interesse daran hat, das mal auf einen aktuellen Stand zu bringen. Vielleicht funktioniert es mit neueren LAV Filters, vielleicht auch nicht.

    Hier mal noch ein lokales Archiv bei mir. Die enthaltene README.txt erklärt relativ ausführlich, welche Modi zum Laden der LAV Filters unterstützt werden; wenn das direkte Laden der AX-Dateien aus einem Unterverzeichnis (Modus L1 oder L3) nicht klappt, kann man immer noch über DirectShow-Funktionen eine im System installierte Version laden (Modi L0 oder L2).

    Auf gute Zusammenarbeit:

    REGELN befolgen | SUCHE benutzen | FAQ lesen | STICKIES beachten




Seite 1 von 2 12 LetzteLetzte

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Ähnliche Themen

  1. graue ruckelbilder am anfang(wmv)
    Von trian im Forum AviSynth
    Antworten: 1
    Letzter Beitrag: 23. May 2007, 12:47
  2. graue Streifen im Bild (XviD)
    Von TheOneFaker im Forum MPEG-4-Encoding
    Antworten: 8
    Letzter Beitrag: 15. November 2006, 23:37
  3. frames am anfang lassen sich nicht entfernen - VirtualDubMod
    Von puntipik im Forum MPEG-4-Encoding-Tools
    Antworten: 15
    Letzter Beitrag: 10. November 2004, 17:02
  4. Ruckeln nach Umwandeln von Frames von 23 frames in 25 oder 29 frames
    Von shadowkai im Forum Video-Bearbeitung & Frameserving
    Antworten: 8
    Letzter Beitrag: 19. March 2004, 04:07

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •