Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 25

Thema: neues Avidemux startet nicht

  1. #1
    Foren As
    Registriert seit
    6. August 2008
    Beiträge
    83

    Standard neues Avidemux startet nicht

    Hallo,

    wenn ich Avidemux 2.6.19 oder 2.6.18 portable unter XP SP3 starten möchte, blitzt nur kurz ein Fensterrahmen auf und dann wird es wieder beendet.
    Wenn ich die beiden Versionen in einer VM mit XP SP3 starte, laufen sie.

    Hat jemand einen Tipp, wie ich die neuen Versionen von Avidemux ans Laufen bekommen kann?

  2. #2
    Erklär-Bär Avatar von LigH
    Registriert seit
    19. April 2003
    Ort
    OPAL-Invalidengebiet Altmark
    Alter
    42
    Beiträge
    42.383

    Standard AW: neues Avidemux startet nicht

    Schau mal, ob sich in %APPDATA%\avidemux Dateien der Form admlog*.txt befinden. Vielleicht steht da was zur Ursache, warum es nicht startet.

    Auf gute Zusammenarbeit:

    REGELN befolgen | SUCHE benutzen | FAQ lesen | STICKIES beachten




  3. #3
    Foren As
    Registriert seit
    6. August 2008
    Beiträge
    83

    Standard AW: neues Avidemux startet nicht

    Danke. Das ist schon mal ein Anhaltspunkt.

    Die letzten Zeilen sind bei der 2.6.19, als auch bei der 2.6.18 portable:

    Code:
    Probing for DXVA2...
    [init] 16:45:49-040 Probing for D3D support
    [init] 16:45:49-415 D3D library loaded, creating instance

    Wenn ich die portable Version in der VM starte, in der sie läuft, wird die Logdatei viel größer. Dort, wo sie beim Host-OS abbricht steht:

    Code:
    Probing for DXVA2...
    [init] 16:56:05-608 Probing for D3D support
    [init] 16:56:06-590 D3D library loaded, creating instance
    [ADM_FAILED] 16:56:06-680 Failed with error code=0x8876086a
    [init] 16:56:06-770 D3D:Cannot create d3d9 device
    [init] 16:56:06-820 D3D:D3D init failed
    [dxva2Probe] 16:56:06-850 D3D init failed
    DXVA2 not available
    Probing for SDL...
    Probing for SDL...
    Calling initSDL with driver=dummy

    Auf beiden Systemen ist die gleiche Version von Direct X 9.0c installiert.

    Jetzt wäre ein weiterer sachdienlicher Tipp gut :-)

  4. #4
    Foren As
    Registriert seit
    6. August 2008
    Beiträge
    83

    Standard AW: neues Avidemux startet nicht

    Inzwischen habe ich von einem Bekannten erfahren, dass es sich bei ihm genauso verhält. Im nativen XP lässt sich AD nicht starten. Unter XP in einer VBox-VM unter Linux läuft es. Es sieht ganz so aus, als wäre AD für XP von den Entwicklern ausschließlich in einer VM getestet worden - was ich ihnen keineswegs übel nehmen würde.

  5. #5
    Erklär-Bär Avatar von LigH
    Registriert seit
    19. April 2003
    Ort
    OPAL-Invalidengebiet Altmark
    Alter
    42
    Beiträge
    42.383

    Standard AW: neues Avidemux startet nicht

    Dann sollte man das besser dort besprechen, wo die Entwickler mitlesen: im Bugtracker.

    Auf gute Zusammenarbeit:

    REGELN befolgen | SUCHE benutzen | FAQ lesen | STICKIES beachten




  6. #6
    Foren As
    Registriert seit
    6. August 2008
    Beiträge
    83

    Standard AW: neues Avidemux startet nicht

    Die Seite sieht nicht gut besucht aus. Unregistriert kann man dort vermutlich nichts schreiben und bei der Registrierung wollen die etliche Sachen wissen, dass ich annehme, dass nicht jeder dort schreiben soll, sondern nur Fachleute.
    Ich kenne noch avidemux.org, aber meine Registrierung ist ungültig und die Mail zum Resetten des Passworts kommt nicht an. Vielleicht schafft sie es morgen.

  7. #7
    König Avatar von Andreas Blöchl
    Registriert seit
    4. September 2003
    Ort
    FCNiederbayern
    Beiträge
    751

    Standard AW: neues Avidemux startet nicht

    Wo hast du denn die Portabel Version her. Lade dir mal die ganz normale Version und entpacke die Zip mit 7-Zip und starte von dem entpackten Ordner dann die exe. Ich mache mir so meine Portable Version immer selber, gehe aber nicht jede Version mit. Brauche Avidemux nur zum mergen von meinen Videofiles vom Handy.
    mfG Andreas
    Go through life with honesty

  8. #8
    Foren As
    Registriert seit
    6. August 2008
    Beiträge
    83

    Standard AW: neues Avidemux startet nicht

    Die portable Version habe ich von chip.de. Die offizielle Version habe ich von sourceforge. Dort gibt es aber nur Installer (.exe), die ich mit 7z entpackt habe. Das ergibt dann aber keine "richtige" portable Version, denn Avidemux benutzt dann die Systemvariablen um Anwendungs- und Benutzerdateien auf dem Systemlaufwerk abzulegen. Egal welche Version ich getestet habe (auch nightlys), die starten alle nicht, bzw. nur in der VM.

    Ich habe das Problem inzwischen eingegrenzt. Wenn ich die d3d9.dll aus den Systemverzeichnissen von XP lösche, dann startet avidemux. Alternative kann man auch die 3D-Beschleunigung in dxdiag oder unter Anzeige -> Eigenschaften -> Einstellung -> Erweitert -> Problembehandlung -> (Schieberegler).
    Das erklärt auch, wieso Avidemux in der VM läuft, denn dort habe ich keine 3D-Beschleunigung installiert.

    Ich habe das Problem inzwischen auch bei avidemux.org geschildert. Vielleicht findet sich eine Entwickler, den es interessiert und der Abhilfe schaffen kann. Eigentlich brauche ich kein 3D, aber ich möchte es auch nicht dauerhaft deaktivieren, denn wenn ich es mal benutzen möchte, denke ich bestimmt nicht mehr daran, dass es deaktiviert ist.


    EDIT:

    Kann man Avidemux vielleicht mit einem Parameter oder eine Configdatei anweisen, keine 3D-Beschleunigung zu benutzen?
    Geändert von Schnarchnase (1. April 2017 um 14:58 Uhr)

  9. #9
    König Avatar von Andreas Blöchl
    Registriert seit
    4. September 2003
    Ort
    FCNiederbayern
    Beiträge
    751

    Standard AW: neues Avidemux startet nicht

    Soviel ich sehen konnte legt Avidemux die Settings beim jeweiligen Anwender ab, ansonsten glaube ich ist es komplett Portable. Das machen übrigens sehr viele Portable Versionen so, der VLC Player zum Beispiel ist da auch so programmiert.
    mfG Andreas
    Go through life with honesty

  10. #10
    Erklär-Bär Avatar von LigH
    Registriert seit
    19. April 2003
    Ort
    OPAL-Invalidengebiet Altmark
    Alter
    42
    Beiträge
    42.383

    Standard AW: neues Avidemux startet nicht

    Den Begriff "portabel" legen die einen enger aus, die anderen weiter. Eine gewisse Basis ist die Vermeidung von Bindungen an das System, die evtl. ein Administrator erlauben müsste; dazu zählt oft schon die Installation zusammen mit der Registrierung von Deinstallationsdaten, aber auch die Verknüpfung an Dateitypen. Bei manchen Programmen, die "portabel gemacht werden", erfordert das sogar eine Integration in eine Art Sandbox, damit in deren Inneren die Systemintegration nur simuliert wird; dadurch kann man sie dann auch nur gemeinsam mit der ganzen Sandbox auf andere PCs kopieren. Andere Programme vermeiden von vorn herein Änderungen in Systembereichen und beschränken sich auf einen Verzeichnis-Ast, der dann aber Schreibrechte braucht und außerhalb der UAC liegen sollte (also z.B. nicht unter C:\Programme). Für deren "Installation" genügt dann das reine Entpacken.

    Auf gute Zusammenarbeit:

    REGELN befolgen | SUCHE benutzen | FAQ lesen | STICKIES beachten




Seite 1 von 3 123 LetzteLetzte

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Ähnliche Themen

  1. Avidemux Joblist nicht mehr zu bearbeiten
    Von bergh im Forum MPEG-4-Encoding
    Antworten: 1
    Letzter Beitrag: 23. May 2016, 14:36
  2. Avidemux mag Virtualdub Captures nicht
    Von AlexMineiro im Forum Video-Bearbeitung & Frameserving
    Antworten: 5
    Letzter Beitrag: 13. January 2007, 23:12
  3. AGK startet nicht
    Von Lindy im Forum MPEG-4-Encoding-Tools
    Antworten: 1
    Letzter Beitrag: 13. March 2006, 19:58
  4. VirtualVCR Scheduler startet nicht und uhrzeit stimmt nicht
    Von atari im Forum Analoges Video-Capturing
    Antworten: 2
    Letzter Beitrag: 1. April 2004, 15:22
  5. CCE startet nicht
    Von Ricky Fitts im Forum MPEG-2 Encoding
    Antworten: 11
    Letzter Beitrag: 23. September 2003, 00:23

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •