Ergebnis 1 bis 7 von 7

Thema: Audio Delay bei HEVC Material

  1. #1
    Kaiser
    Registriert seit
    5. December 2007
    Beiträge
    1.193

    Standard Audio Delay bei HEVC Material

    Hallo zusammen,

    ich habe bei mir folgenden Effekt festgestellt:

    Mediainfo zeigt mir kein Delay im Ursprungs-Container an. Weder Audio noch Video ...
    Auch habe ich das AAC Audio 1:1 übernommen ... also nich reencoded.
    Mit yamb/mp4box aus .mp4 extrahiert und direkt mit dem neuen HEVC Stream in Matroska gemuxed.

    Wenn ich dann einen AVC Video Stream re-encode in HEVC habe ich danach ein Audio Delay von -100 bis -250 ms.
    Und das obwohl die Anzahl der Frames absolut gleich ist ... Oder hat sich am Matroska Container in letzter Zeit was geändert was diesen Effekt hervorruft ?
    Hat noch jemand anders auch diese Phänomen ?

  2. #2
    Kaiser
    Registriert seit
    6. July 2009
    Beiträge
    1.274

    Standard AW: Audio Delay bei HEVC Material

    Das ist kein inhärentes HEVC-Phänomen. Ohne Samples und genaue Angaben zu dem, was gemacht wurde, läßt sich ansonsten nicht viel dazu sagen.

  3. #3
    Kaiser
    Registriert seit
    5. December 2007
    Beiträge
    1.193

    Standard AW: Audio Delay bei HEVC Material

    Ok, es scheint an den Wiedergabe Filtern zu liegen.

    Aber ...

    Ich habe das Ursprungs Video via L-SMASH-Works-r804-20151004-32bit geöffnet und das Audio Delay entsprechend korrigiert.
    Das waren rund -300ms. Soweit so gut, alles Lippensyncron und auch der MPC-HC hat das Ganze richtig wiedergegeben.

    Nun hab ich den Clip auf meiner NAS Storage abgelegt (Samba kein DNLA !) und von meinem HTPC abgespielt.
    Der Ton ist um genau die 300ms zum Bild verschoben.

    Spielt man auf meinem Encoding-Rechner das Ganze mit VLC ab, gibt's den gleichen Effekt.

    D.h. es muss am ... Tja was liegen ???
    Mein HTPC verwendet ebenfalls die neusten LAV-Filter. Nirgendwo ist ein Delay gesetzt ! Splitter müßten ebenfalls die selben sein ... Mir fällt nichts mehr ein

  4. #4
    Kaiser
    Registriert seit
    5. December 2007
    Beiträge
    1.193

    Standard AW: Audio Delay bei HEVC Material

    Hm ... keiner 'ne Idee ?
    Gibt es eine Möglichkeit eines "GLobalen Audio Delays" ?
    Sprich - egal welcher Audio Decoder verwendet wird, es wird immer ein Audio Delay gesetzt.
    (war da nicht maol sowas bei der Verwendung von HDMI ?)

    Erschwerend kommt hinzu das die WIN7 Kiste 'ne VM ist (VirtualBox)

  5. #5
    . Avatar von Selur
    Registriert seit
    19. April 2003
    Ort
    underground
    Beiträge
    24.685

    Standard AW: Audio Delay bei HEVC Material

    Würde erst mal gucken ob:
    • der Delay auch da ist wenn das file direkt auf dem HTPC liegt und nicht über Netzwerk wiedergegeben wird
    • eventuell die CPU ausgelastet ist. Wie hoch ist die CPU Auslastung auf dem HTPC bei der Wiedergabe


    Spielt man auf meinem Encoding-Rechner das Ganze mit VLC ab, gibt's den gleichen Effekt.
    Wie ist die CPU Auslastung? Wird die letzte nightly Version genutzt? Wie sieht es aus wenn MPC verwendet wird?

    Spiele hier ohne Probleme HEVC mp4 files über NAS Samba Freigabe wieder, ist definitiv kein generelles Problem, sondern liegt an Deinem System, Deiner Hardware bzw. den Treibern&Co die Du verwendest.

    Cu Selur

  6. #6
    Kaiser
    Registriert seit
    5. December 2007
    Beiträge
    1.193

    Standard AW: Audio Delay bei HEVC Material

    nee ...
    Auf dem HTPC läuft alles Super ohne jegliches Delay.
    Nur auf meinem Rechner auf dem ich codiere gibt's das Delay beim abspielen durch den MPC-HC ... nicht bei der Verwendung von VLC.

    Das merkwürdige ist ja das Avisynth (mit Lsmash-works) ebenfalls das Delay-Problem hat ... aber halt auch nur auf diesem Rechner ...
    Ich tippe mal da auf den Ausgabe-Filter ... Aber im Graph-Edit sah alles ok aus ...

  7. #7
    Kaiser
    Registriert seit
    5. December 2007
    Beiträge
    1.193

    Standard AW: Audio Delay bei HEVC Material

    ok, Problem gelöst ... erst mal.

    Der "root-cause" was das Audio Sub-System des VirtualBox. Das stand auf Pulseaudio.
    Habe es auf ALSA umgestellt und siehe da, das Delay ist verschwunden.

    ... Hm, vielleicht sollte man diesen Beitrag hier in die Linux Sektion verschieben ...

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Ähnliche Themen

  1. Audio Delay bestimmen
    Von MMVidzProf im Forum Video-Bearbeitung & Frameserving
    Antworten: 15
    Letzter Beitrag: 29. January 2011, 17:56
  2. Wie Audio Delay herausfinden?
    Von DJ-Spacelab im Forum Video-Bearbeitung & Frameserving
    Antworten: 5
    Letzter Beitrag: 13. March 2007, 18:28
  3. AVI audio delay auslesen ?
    Von Zahnrad im Forum MPEG-4-Encoding-Tools
    Antworten: 18
    Letzter Beitrag: 30. July 2005, 20:20
  4. Audio-Delay und Diverses
    Von eciman im Forum Analoges Video-Capturing
    Antworten: 6
    Letzter Beitrag: 24. November 2004, 23:30
  5. AVI Audio Delay
    Von Argbeil im Forum Video-Bearbeitung & Frameserving
    Antworten: 2
    Letzter Beitrag: 1. September 2003, 12:01

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •