Seite 1 von 11 123 ... LetzteLetzte
Ergebnis 1 bis 10 von 110

Thema: 10 Bit debanding

  1. #1
    Kaiser
    Registriert seit
    5. December 2007
    Beiträge
    1.193

    Standard 10 Bit debanding

    Hi hab da mal folgendes Problem:
    Ich reencode meine Animes nach 10 bit AVC. Doch jetzt ist mir aufgefallen das doch einiges an Banding zu sehen ist.
    Zuerst hatte ich x264 in Verdacht, aber nachdem ich mir das Ganze im VDM nochmal angesehen habe mußte ich feststellen das der obere Stack nahezu komplett frei von Banding ist und der unteren Stack den Teil der für die Schlieren verantwortlich ist. (Siehe Bild 1)
    Encoded man das nun mit x264 werden die Beiden Stacks ja übereinander gelegt und man sieht den Effekt sehr stark.
    Das passiert auch wenn man DitherPost() aktiviert - oder GradFun3() wegläßt.

    Kann sich da jemand einen Reim drauf machen ? Was kann man dagegen tun ?

    hier ist mein avs:
    Code:
    LWLibavVideoSource("Hell_Girl.mkv")
    dfttest(Sigma=1,lsb=true)
    
    clip=last
    
    sup = clip.MSuper(Pel=2)
    backward_vec = sup.MAnalyse(isb = true, truemotion=true, search=5, dct=8, trymany=true )
    forward_vec = sup.MAnalyse(isb = false, truemotion=true, search=5, dct=8, trymany=true ) 
    
    
    MDeGrain1(clip,sup,backward_vec,forward_vec)
    dfttest(Sigma=4,dither=1,tbsize=1)
    
    Dither_resize16(1280,722)
    MSharpen(strength=190)
    GradFun3()
    Dither_crop16(0,0,0,-2)
    
    Dither_quantize(bitdepth=10, mode=7,reducerange=true)
    Dither_out()
    #DitherPost()
    
    return(last)
    (Das Bild 1 ist hier nicht so qualitativ wie oben beschrieben. Das liegt daran das ich es nach jpg gewandelt habe. An sonsten wäre es 7.3 MB groß)

    Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	hell1.jpg 
Hits:	101 
Größe:	630,1 KB 
ID:	97754Klicken Sie auf die Grafik für eine größere Ansicht 

Name:	hell2.jpg 
Hits:	87 
Größe:	20,3 KB 
ID:	97753
    Geändert von may24 (11. September 2013 um 22:07 Uhr)

  2. #2
    Erklär-Bär Avatar von LigH
    Registriert seit
    19. April 2003
    Ort
    OPAL-Invalidengebiet Altmark
    Alter
    42
    Beiträge
    42.310

    Standard AW: 10 Bit debanding

    Sieht hier irgendjemand ein Bild?

    Auf gute Zusammenarbeit:

    REGELN befolgen | SUCHE benutzen | FAQ lesen | STICKIES beachten




  3. #3
    . Avatar von Selur
    Registriert seit
    19. April 2003
    Ort
    underground
    Beiträge
    24.672

    Standard AW: 10 Bit debanding

    @LigH: Nö
    @may24: Wie fütterst Du den x264 mit dem erweiterten Farbraum? (soweit ich mich entsinne muss man dazu avs2yuv verwenden und in der x264 command line irgendwie explizit angeben was für einen Farbraum man hat,...)

  4. #4
    Kaiser
    Registriert seit
    5. December 2007
    Beiträge
    1.193

    Standard AW: 10 Bit debanding

    Boa, endlich ... zusätzlich zu den "üblichen" Forumsproblemen (500) kommt jetzt auch noch eigene Internet Verbindungsprobleme hinzu. Hab drei Anläufe gebraucht um wenigstens den Thread zu starten. Ganz zu schweigen von Bilder hochladen...

    Na ja. Hier ist meine x264 cli:
    Code:
    "C:\Program Files (x86)\Video Tools\avs2yuv\avs2yuv.exe" -raw "hell.avs" -o - | "C:\Program Files\x264\x264-10bit-r2358.exe" --crf 17 --level 4.1 --b-adapt 2 --bframes 3 --ref 5 --partitions all --direct auto --weightb --me umh --subme 10 --mixed-refs --no-fast-pskip --no-dct-decimate --vbv-bufsize 30000 --vbv-maxrate 38000 --trellis 2 --threads auto --output hell-17-10.h264 --demuxer raw --fps 25 --input-depth 10 --input-res 1280x720 -

  5. #5
    Kaiser
    Registriert seit
    6. July 2009
    Beiträge
    1.270

    Standard AW: 10 Bit debanding

    Die Ein- und Ausgabe von GradFun3() ohne zusätzliche Parameter ist 8 Bit, wirf dazu einen Blick in die Dokumentation. Beachte bei jedem Filter, ob die Eingabe 8 Bit oder 16 Bit ist, und ob die Ausgabe 8 Bit oder 16 Bit ist. Jeder Filter muß die jeweilige Ein- und Ausgabe ausdrücklich unterstützen, sonst produzierst Du nur Müll.

  6. #6
    Kaiser
    Registriert seit
    5. December 2007
    Beiträge
    1.193

    Standard AW: 10 Bit debanding

    Ok, das scheint's gewesen zu sein
    Mir ist allerdings nicht klar warum lsb=true und lsb_in=true gesetzt sein muß damit's richtig dargestellt wird.

    Da wäre aber nochwas. Der GradFun produziert scheinbar eine 2px Linie am unteren Rand. Deshalb das Resizing auch auf 1280x722 und der Crop(0,0,0,-2)
    Weiß jemand warum ?

  7. #7
    Kaiser
    Registriert seit
    6. July 2009
    Beiträge
    1.270

    Standard AW: 10 Bit debanding

    Ein- und Ausgabesample und Dein aktuelles Skript.

  8. #8
    Kaiser
    Registriert seit
    5. December 2007
    Beiträge
    1.193

    Standard AW: 10 Bit debanding

    Skript siehe oben - bis auf die Zeile: GradFun3(lsb=true, lsb_in=true)
    Sample lade ich morgen hoch ...

  9. #9
    Kaiser
    Registriert seit
    6. July 2009
    Beiträge
    1.270

    Standard AW: 10 Bit debanding

    Und alle Deine Funktionen arbeiten mit 16 Bit stacked? Kann ich mir nicht vorstellen. Siehe Beitrag #5.
    Geändert von sneaker2 (13. September 2013 um 16:26 Uhr)

  10. #10
    Kaiser
    Registriert seit
    6. July 2009
    Beiträge
    1.270

    Standard AW: 10 Bit debanding

    Achso, den Sample-Upload kannst Du Dir erst mal sparen. Wenn Du Dein Skript auf 8 Bit/16 Bit-Ein- und Ausgabe hin korrigiert hast, wird der Fehler verschwinden.

Seite 1 von 11 123 ... LetzteLetzte

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Ähnliche Themen

  1. debanding mit gradfun2db??
    Von Smasch im Forum AviSynth
    Antworten: 1
    Letzter Beitrag: 4. August 2012, 12:23

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •